"Success (Active)" WebApp deployment from GitLab CICD doesn't actually update app

Andras Pongo 5 Reputation points
2023-10-25T07:57:56.2133333+00:00

Hello,

I have an Azure WebApp to which I'm deploying to from a GitLab CICD pipeline. The application is a SOAP WebService written in Java 11, deployed as WAR, to a Free (F1) SKU on Windows.

Initially I've setup the deployment from GitHub, through the UI, and it worked perfectly, my app was deployed and I tested it from Postman, receiving the expected SOAP response, proving the application is actually up and running.

Then I moved my repo over to GitLab, and started deploying from there using a new CICD pipeline. This seemed to worked well, as I could clearly see each pipeline run as a new deployment entry as Success - and the last one as Success (Active) - in the Logs under Deployment Center, BUT the application did not seem to be actually updated with the changes. This is clear from the fact that I've updated the response object but I'm still getting the old one in Postman.

AzureWebAppDeploymentSuccess.png

What am I missing? Is it a caching issue? Or the successful deployments are not actually true?

Note1: Additionally I also tried to setup a completely new WebApp and deploy there right away from GitLab. Here the surface behaviour seem to be the same, Logs section in the Deployment Center shows Success, but this time my app doesn't even seem to be deployed at all, as instead of my application's SOAP response I'm getting the generic "" HTML page from Azure.

Note2: In my pipeline I'm also running Ansible to inject an environment variable (APP_VERSION), which runs after the deploy job. I can see this variable being updated with each deployment under Configuration/Application settings, so clearly, the pipeline is doing what it supposed to, except the appication code itself doesn't seem to be updated somehow. See screenshots below.

AzureWebAppEnvVariableOK.png

So at this point it seems the deployment don't actually deploy anything somehow. Any tips please? Thank you!
/András

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,193 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. ManoharLakkoju 690 Reputation points Microsoft Vendor
    2023-10-25T12:56:44.8233333+00:00

    @Andras Pongo
    Welcome to Microsoft Q&A Platform, thanks for posting your query here. Azure DevOps related queries/issues are currently not supported on this Microsoft Q&A platform.

    I would request you to please post your queries in dedicated forums as in below links:

    https://developercommunity.visualstudio.com/spaces/21/index.html

    https://developercommunity.visualstudio.com/t/get-unique-id-from-devops-     organization/756710

    https://stackoverflow.com/questions/tagged/azure-devops

    0 comments No comments