Remote Desktop Session (RDS) stuck black screen Windows Server 2016

bunyoeun loeun 0 Reputation points
2023-10-25T08:43:47.0266667+00:00

When Remote Desktop Session (RDS) hang black screen

I found the event:An error occurred when transitioning from CsrConnected in response to EvCsrInitialized. (ErrorCode 0x80004005)

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,418 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,340 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Krasimir Rangelov 80 Reputation points
    2023-10-28T12:49:13.5233333+00:00

    I would suggest you to restart all of the Remote Desktop Services and check if anything changes.

    If the issue still persists, please check if there's any GPO enabling FIPS compliant algorithms.

    Navigate to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> System Cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing

    And if the option System Cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing is Enabled try to Disable it, then perform gpupdate /force, then restart the Remote Desktop Services again and try to connect.

    If still not connecting, recheck that the option System Cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing is still disabled, and I would suggest to navigate to Computer Configuration ->Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Security -> Require use of specific security layer for remote (RDP) connection enable the policy and select from Security Layer option RDP, then gpupdate /force, restart the Remote Desktop Services and try to connect.

    If the Answer is helpful, please click "Accept Answer" and upvote it. ❤

    0 comments No comments