Warnings when doing Linux file level restore in Azure

Rob Nicholson 41 Reputation points
2023-10-25T17:38:56.19+00:00

I often mount the file restore points for a Linux file level backup on a test virtual machine based on my network. The downloaded Python script works fine but recently, it's been giving this warning:

Your system doesn't have access to 'pod01-rec2.ukw.backup.windowsazure.com' on port 3260 (outbound). ILR Script won't be able to run successfully. Please add rules in the NSG to allow 'pod01-rec2.ukw.backup.windowsazure.com' on port 3260 (outbound), and also allow Public DNS resolution on port 53 (outbound). Please press 'N' to abort the operation. Press 'Y' if you still want to continue with running the script : y

If I say "Y", the script works fine. It mounts the backup volumes and I can access the backup.

But why has this warning started over the past few months? This Linux VM will have full outbound port access AFAIK and the same error occurs even if I disable firewall-cmd.

I assume that I because I can ping pod01-rec2.ukw.backup.windowsazure.com that public DNS resolution on port 53 is open. Not sure about port 3260. Could I try a telnet to it on that port?

When I run the same restore scripts on the actual Azure based VM, the warnings don't appear.

Azure Backup
Azure Backup
An Azure backup service that provides built-in management at scale.
1,163 questions
{count} votes