How to fix no access (error 403) issue in Asure Portal?

Srivastava, Sakshi 0 Reputation points

I am facing this error even after having good connectivity and access: Failed to load one or more resources due to no access, error code 403.
I did manual troubleshooting but that gives me no issues status. Kindly let me know how this can be fixed. User's image

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
3,804 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Harishga 940 Reputation points Microsoft Vendor

    Hi Srivastava, Sakshi,

    Thanks for the question and using MS Q&A platform.

    Could you please confirm the permission on the Synapse workspace which you are trying to login?

    According to the official documentation: Azure Synapse access control

    To create these resources, you need to be an Azure Owner or Contributor on the resource group. To manage them once created, you need to be an Azure Owner or Contributor on either the resource group or the individual resources.
    User's image

    According to the official documentation: Synapse RBAC Roles

    The following table lists the built-in roles and the actions/permissions that each support.

    User's image

    Adding permission on the Synapse Portal: Access control: Synapse AdministratorUser's image

    Make sure you have required permissions to access workspace:

    • From Azure Portal under Synapse Workspace, user needs to have Owner/Contributor permission.
    • From Azure Portal under Synapse Workspace, user needs to enable correct IP address under firewall settings.

    After grant the required permissions, you can try the below options:

    Option1: Try to manually login by going to the and sign into your workspace.

    User's image

    For more information, refer to the Open Synapse Studio

    Option2: You please try the below:

    1. Clear “Cookies and Cached data” of your browser.
    2. Private Mode (New InPrivate Window).
    3. Try in different browser.

    Additionally, checkout this article - Disabling Public Network Access in Synapse helps to resolve the issue.

    And also Watch this video to learn how to disable public network access.

    In case, none of the steps worked for you - kindly share the screenshot of the permission you had on the Azure Synapse Workspace from Azure Portal and Azure Synapse Portal.

    Hope this helps. Do let us know if you any further queries.

    If this answers your query, do click Accept Answer and Yes for was this answer helpful. And, if you have any further query do let us know.