How do I resolve code 0x0000232B RCODE_NAME_ERROR when my dns server is correctly assigned on my workstations.

Jordan Tolan 25 Reputation points

The issue has been resolved. The answer is at the bottom of this article and in the comments. A little bit of background: Hi, My name is Jordan. I installed a Dell PowerEdge T440 for a tax company and started setting up my DNS and AD DC like usual. Installing Windows Server 2022, Staticly assigning the IP address. Then set up a Windows server backup and got the latest drivers from Dell. After that, I added DNS and Active directory DC. Then set up my domain by creating a forest and restarting the server once again. after that, I went into the DNS settings and set up my forwarders and (In the DNS server properties) everything looked fine the forward lookup zones were there and it should now be able to accept computers to join it. I then went to join one of the workstations through system properties and got this error when typing my FQDN.

Error: "The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "BRR.INTERNAL":

The error was: "DNS name does not exist."

(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.BRR.INTERNAL

Common causes of this error include the following:

  • The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:

  • One or more of the following zones do not include delegation to its child zone:



. (the root zone)"

More Background: After I saw that message I went straight to the router thinking my DNS was assigned wrong through the DHCP server on the Comcast modem/router Combo but is the IP address I assigned the server as well as the primary and secondary DNS I added to the DHCP server on the router right after I created the domain. Next, I started looking for issues other people had but everywhere online it was just the same stuff and answers. Double-check the DNS on your client which I did. I even just statically assigned an IP to the workstation and told it to use as the DNS. Next, it says to Re-Register the DNS records on the Server. I deleted both forward lookup zones and then ran the command "ipconfig /registerdns" It just added them back. I then pinged my domain controller by name "bbr.internal" and got no response but I can ping the server "" I then made sure the firewall allowed port 53 by running "test-netconnection -port 53" after that I ran this command to see if the workstation could resolve the domain "Resolve-DNSName bbr.internal" and it failed. It's gotta be the DNS server records is what I'm thinking. I don't get it. I searched for how to fix srv records but it says they refresh so I forced them to refresh with no success. The server and workstations have been restarted many times during the troubleshooting and Windows Server has been reinstalled and re-setup with a DVD and Rufus flash drive to see if it was a corruption issue. The only thing inbetween them is the Comcast router which I removed all firewall and content filtering and reset to default during troubleshooting. I can ping each other's IP so I don't know how it would be an issue.

A website that helped me troubleshoot a lot: ""

Specs and devices and Network information.

Three Dell Vostro 3020 T's that have had drivers and bios updated the second I plugged them in and an IP address of on the testing workstation, others I tried with wifi and wired DHCP

Screenshot 10_27_2023 4_33_27 PM

A003 - Google Chrome 10_27_2023 4_37_42 PM

Screenshot (14)

One PowerEdge T440 has an IP of and a DNS address of its loopback IP. That is configured with a domain name of "bbr.internal" and Net bios name "bbr" Foward lookup zones have been remade with the command located at the beginning of this cry for help.

Screenshot (23)

Screenshot (24)

Screenshot (17)

Screenshot (16)

Screenshot (15)

One Comcast CBR2-T Modem/router combo. Has a DHCP server configured to send out IP addresses Between with an IP of, subnet, and DNS servers being Has been reset multiple times and had content filtering and firewall settings turned off. (which is not needed but done so I don't get stupid answers from young blood on here)

Screenshot (18)

Screenshot (20)

Screenshot (22)

Let me know what I should do or If I'm just blind and missing something right in my face. Let me know things that will help you understand the situation I will edit and revise this as much as you want me to so I can get this resolved. (Solution) Dcdiag command helped me find the AAAA record issue which led me to some people having issues with IPv6 when joining a domain. After disabling IPV6 on my server, router DHCP Server, and turning it off on my workstation it worked. I'd assume it was because the workstation was looking for DNS info through the IPv6 Comcast DNS addresses from the router and not at my ipv4 DNS that I manually entered.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
11,130 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
5,153 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 416.8K Reputation points MVP

    Please run;

    Dcdiag /v /c /d /e /s:%computername% >C:\dcdiag.log (run on PDC emulator)
    repadmin /showrepl >C:\repl.txt (run on any domain controller)
    ipconfig /all > C:\%computername%.txt (run on EVERY domain controller)
    ipconfig /all > C:\problemworkstation.txt (run on problem pc)

    Also check the domain controller System and Replication (DFS or FRS) event logs for errors since last boot. Post the Event Source and Event IDs of any found. (no evtx files)

    then put unzipped text files up on OneDrive and share a link.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Jordan Tolan 25 Reputation points

    After disabling IPV6 on my server, router DHCP Server, and turning it off on my workstation it worked. I'd assume it was because the workstation was looking for DNS info through the IPv6 Comcast DNS addresses from the router and not at my ipv4 DNS that I manually entered.

    1 person found this answer helpful.