Error while connecting data to Azure Open AI service Preview option

Paarthvi Sharma 15 Reputation points

Hi Team,

I am connecting my data with OpenAI service using the Preview feature. While doing so, I have enabled vector search and added an embedding model. We have also selected the semantic search standard plan and enabled Hybrid + Vector Search. This setup was working previously but after the recent deployment it keeps on giving me the error:

I have an embedding model already in place and I am able to interact with the data in the AI Studio. However once the application is deployed onto the web app this error is showing up.

Any suggestions?
User's image

Azure Cognitive Search
Azure Cognitive Search
An Azure search service with built-in artificial intelligence capabilities that enrich information to help identify and explore relevant content at scale.
499 questions
Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
1,871 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. suraj sharma 85 Reputation points

    The error message you’re seeing, 'embeddingEndpoint' is a required parameter for the AzureCognitiveSearch data source type, indicates that you need to include the ‘embeddingEndpoint’ parameter when configuring the Azure Cognitive Search data source for your application.

    This parameter is required when you’re using the vectorSimpleHybrid query type, which combines both semantic and vector search. The ‘embeddingEndpoint’ should point to the endpoint of your embedding model.

    Please replace 'YOUR_EMBEDDING_MODEL_ENDPOINT' with the actual endpoint of your embedding model2.

    Here’s an example of how you can include this in your configuration:

    "dataSources": [
        "type": "AzureCognitiveSearch",
        "parameters": {
          "embeddingEndpoint": "'YOUR_EMBEDDING_MODEL_ENDPOINT'"

  2. Paarthvi Sharma 15 Reputation points

    Hi Suraj, thanks for responding to my query but the problem is that this application has been deployed from Azure Open AI Studio and I just selected the embedding model from the default drop down menu. Add Data Source> Blob Storage > Selected the container and search service > Clicked the vector embedding option.

    User's image

  3. NFMi 0 Reputation points


    I had the same problem and solved it by setting two environment variables:

    AZURE_OPENAI_EMBEDDING_ENDPOINT = https://{your-resource-name}/openai/deployments/{deployment-id}/extensions/chat/completions?api-version={api-version}

    You can set the environment variables in by navigating to your web app through App-Services in the azure portal. (As API version, "2023-08-01-preview" worked for me.)

    I hope that helps.

    0 comments No comments