Virtual Disk, Hyper-V Network connections, they won't go away!

Starrxsource 0 Reputation points

(This post was origianally located at, but I was instructed to instead post here.)

I consider myself a pretty good IT and computer specialist. I have learned from experience and have no formal training, I figure out computer stuff as I go along, and I have amassed a pretty large repertoire when it comes to my abilities with computers. However, my latest problem is not one I would like to tackle alone, simply because I have never experienced a problem like this, and it seemed to come out of nowhere. I'll explain my problem after I list my specs and findings, because I feel like you would gain more context from it.

Here are my computer specs:

  1. Windows 10 Pro (Version 22H2)
  2. OS (Manually) Installed on 08/18/2023
  3. OS Build: 19045.3570
  4. Windows Feature Experience Pack 1000.19052.1000.0
  5. Intel Core i5 6500 @3.20 GHz (Don't make fun of me.)
  6. 24GB DIMM DDR4 RAM. 4 slots used, clocking at 2133MHz
  7. Motherboard is an ASUS H170M-PLUS
  8. OS is installed on SATA Samsung SSD 850 EVO 250GB (Internal) (No page file and I 9. try to use the least amount of writes possible)
  9. 1TB WDC (Western Digital) SATA HDD (WDC WD10EACS-00D6B0) (Internal) (I try to get as many applications as possible installed on here)
  10. 500GB Samsung PSSD T7 (External) (For Stuff)
  11. 1TB Sabrent Rocket Nano SCSI Disk Device (External) (For AOMEI Backups, if you know a better way let me know)
  12. MSI ARMOR Radeon RX 580 8GB OC Edition (Internal Discrete Graphics Card, and the only one the system seems to be using) (running through HDMI)
  13. If it helps, or maybe because I am proud of it, my monitor is the ThinkVision P24h-20 (machine type 61F4) (firmware version LA1.4)

(This was all rehearsed from memory, another flex)

  1. Everything I know is set to high performance, as in with control panel, settings, and just stuff. I haven't set it to Ultimate Performance via command prompt because my PC is not the MSI Titan and could fry like a potato. My RX 580, I just left, because MSI Afterburner was being defiant (see below) and it gets too hot and seemingly unstable with the slightest OC anyways.)

Here are some of the things I have found:

  1. As I was doing routine tasks on my computer, I found that my Task Manager (taskmgr.exe that comes with Windows 10) has three Hyper-V Virtual Ethernet Adapters that show up, and if I disable or uninstall them via Device Manager, they will pop back up on restart (and a few times just on their own without restart, but take that with a grain of salt, since it is inconsistent).
  2. According to Task Manager, after reenabling them, I have a vEthernet (Ethernet), a vEthernet (Ethernet 3), and a vEthernet (Wi-Fi). They will all send a few Mb/s after enablement, but then they are quiet. All are Hyper-V Virtual Ethernet Adapters.
  3. Now it can seem like this problem has to do with Hyper-V, but I did not have Hyper-V enabled when these popped up (maybe I did, but I do not recall) and when I disabled Hyper-V, or at least made sure it was, they did not disappear. I always will have 3 vEthernet Virtual Adapters.
  4. MiniTool Partition Wizard (I checked after Hyper-V became the focus of my investigation) finds that there is a Virtual Drive, listed as Disk 5, that is as follows: Disk 5 - Read Only (Msft Virtual Disk, MBR, 8.00 GB) It has used 510.69MB of the allotted 8GB. It is a primary partition, and the status is listed as none. Where Mini would list the drive letter and the name, it lists Portable Base Layer(NTFS). Funny thing is that it seems to be a completely independent drive, but I am going to guess that it resides in C:. This is a hunch and I cannot back it up with evidence.
  5. I have not used Hyper-V in a way that I would have been aware of it. I know I have enabled it before, but this has been going on so long I do not know if it is before or after stuff started showing up.
  6. I have a 12Mb/s Download speed and a >1Mb/s upload, so I would notice (very definitely) if the Virtual Ethernet Adapters were taking up any bandwidth. However, my network is also very unreliable and very prone to randomly and sporadically disconnect from the internet and refuse to reconnect until the power is pulled and it restarts. It is a Gryphon router, if that helps, I cannot change that it is a Gryphon. That is what it is.

I have a few inklings of what could have possible caused this, but this is rendered to speculation since I cannot back it up with evidence:

  1. I tried to create a Windows To Go with Rufus with a USB 2.0 Drive (yes I know, I cannot help my circumstances). I discovered that it was a bad drive (MiniTool confirmed, I wasn't surprised) and I also was forced to shut down my computer in the middle of one of multiple attempts at Installation. Maybe somehow Rufus made a virtual drive to use as a middleman between my ISO and the USB? I have no idea.
  2. I Recently installed a bunch of programs to my computer, such as LMMS and Foto Sketch, Virtual Studio Code, Everything, BleachBit, Audacity... I don't think that these would create a Virtual Drive.
  3. I have installed programs such as Parsec (Non-portable) and Chrome Remote Desktop. I also have the native Windows Remote Desktop Application on hand and the switch flipped to on in Settings.

That about sums up my problems. The vEthernet Adapters seem to be purely Aesthetic, but due to cybersecurity reasons, I would like them removed. I will not reinstall my Windows, but I am willing to enter into BIOS stuff, as I have done so many times before. I built my computer myself, and I care much for it. I want to make sure I know as much as possible about what it is doing. If it helps to state, knowing why I have the issues with my PC is just as important as knowing how to fix it. If you have the time, please consider leaving a comprehensive response to why it happens and how, as well as how to fix it and what that does. Thank you!

Because of my lengthly description of specs, I would like to put to light some other problems:

MSI afterburner refuses to try and overclock the RX 580. I Have Speedfan Installed and running with curves I like, and I also have AMD Software installed. However, I have tried making MSI Afterburner run without any of these programs running and it still refuses. With the AMD software, I have tried overclocking it there, but have been met with scary driver timeouts, which resulted in a very confused and scared me staring at a frozen or black screen that eventually (not fast enough for a panicked shutdown) came back with the error. This happened with the slightest OC. It was a used RX 580, but it came with all of the original packaging and the dude I got it from didn't have experience to OC it and his PC glowed with LED glory, indicating to me that it was significantly better than my rig. (I made him use the RX 580 before I bought it, and it has worked well without OCing it through an application, it will run War Thunder at Max Graphics with the Full Ultra HD game at the Native Resolution of my P24h-20(2560x1440) without any issues at all except excessive heat. 170F very quickly. I have since reduced the resolution and the graphics settings and jimmy-rigged a new fan.) I am not experienced enough or demented enough to attempt to overclock using SpeedFan. I have tried all I can, I wonder if anyone knows if it has to do with my computer specs? I do not think it is a CPU issue, but my CPU is a 6th Gen, and Microsoft won't let me upgrade to Windows 11 since it requires an 8th gen up, but that may not mean much, since it's more like an enforced suggestion, and I could reimage my PC to 11 in a painstaking process if I really was desperate, and I would not want to end up defenistrating my PC in the process. (That Copilot Feature sounds really nice!)

Anyways I hope this request wasn't too boring. I hope you got a good laugh from my sad specs. Please let me know if you got any tips or stuff. About upgrading my PC and/or Network, trust me, I got it all planned out. :)

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
9,542 questions
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,374 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Dave Patrick 418.6K Reputation points MVP

    With the Hyper=V role and using a desktop OS you'll have at least a vEthernet (default switch). The host may have additional vEthernet adapters if there were additional vSwitches create in Hyper-V Virtual Switch Manager.

    --please don't forget to close up the thread here by marking answer if the reply is helpful--