Testing Active Directory with WinServer 2019 + Win10Pro

Matteo Giacalone 20 Reputation points
Hi, I'm taking a course on active directory, following the instructions I created two virtual machines, one with Windows Server 2019 and one with windows 10 pro.

On the server, the admin is PhAdmin, I installed Active Directory and elevated the server to Domain Controller. I added a few users and groups for practice. The domain is called phoenix.local PHOENIX in NETBIOS. This is obviously also a DNS server, ip, the machines are in bridged mode
Then I switched to the Windows machine, left everything in dhcp and set as DNS, then I changed the name of the PC and instead of workgroup I joined it to phoenix.local, it asked me for an administrator password and I put phoenix \PhAdmin and the related password, everything worked at first glance, it asked me to restart and so I did.
When logging in I saw that it recognizes all the users created in Active Directory and the mapped drives and home folders also work well (when logging in to My Computer two network drives appear which contain respectively the work folder and a reserved folder for each user .
However, from this moment on I am no longer able to make changes to the system, for example changing the date and time, changing the network card settings, much less changing the name of the PC... the previous screen always appears telling me to enter the credentials administrator to make the change but this time it doesn't work, whatever I enter it doesn't recognize the user, the mess is this:
"To continue, enter your administrator username and password (which one? local or domain?)"

after re-entering phoenix\PhAdmin and the related password that had previously worked, I get a red error message that says:
Running with elevated privileges is required to perform the requested operation

and from now on I can't do anything anymore..

Has anyone figured out where the problem is?
Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,149 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
5,143 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 415.1K Reputation points MVP

    Hard to read when you post as a code block. Which are you having the problem with the domain controller or the desktop? For the latter also try logging on as local admin and or try adding you domain admin account as a member of the local administrators group.

    --please don't forget to close up the thread here by marking answer if the reply is helpful--

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful