How to connect to cosmosDB which is in private VNET from azure data studio ?

Abhilash Deshmukh 5 Reputation points

when i am trying to connect to mongo db from azure data studio , i am getting below error when i tried both option connection string/ parameters -

i am getting errro azure resource not found .

can someone provide steps to consider while connecting to cosmos mongodb from azure data studio .

Azure Cosmos DB
Azure Cosmos DB
An Azure NoSQL database service for app development.
1,267 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Vinodh247 7,416 Reputation points

    Hi Abhilash Deshmukh,

    Thanks for reaching out to Microsoft Q&A.

    Did you try this?

    Please 'Upvote'(Thumbs-up) and 'Accept' as answer if the reply was helpful. This will be benefitting other community members who face the same issue.

  2. Abhilash Deshmukh 5 Reputation points

    Hi @GeethaThatipatri-MSFT Vinodh247

    i tried with connection string + host:port 10255.

    just to mention i have private endpoint enabled for this cosmos account .

    attaching error screenshot-

    User's image

  3. GeethaThatipatri-MSFT 24,042 Reputation points Microsoft Employee

    Hi @Abhilash Deshmukh,

    Sorry for the delay in my response

    Can you try the steps provided below.

    Got to Azure portal under your Cosmos DB resource select Azure data studio preview. and Click on Connect with Azure data studio.

    User's image

    Your account will be added in ADS and you should be able to connect.

    User's image

    User's image

    User's image

    I hope the steps will help you to resolve the issue