Microsoft Office 365 sends all our marketing emails to the Junk folder

Santosh Subramanian 0 Reputation points

Hi there,

When I send emails from a marketing platform like ActiveCampaign, all our emails are sent straight to the junk folder.

ActiveCampaign suggested adding the DKIM keys and SPF record, and even after adding these records and authenticating ActiveCampaign, Outlook says the identity of the sender is not verified.

Our customers on Gmail accounts receive the email in the inbox without any problems, however, with our customers on Microsoft Exchange or Office 365, emails go straight to the junk folder.

I also checked the content for spam score, and it is 9.5/10 which is very good.

Why is Outlook sending emails to Junk? Can anyone help me fix this please? ms ticket

A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.
996 questions
A family of Microsoft email and calendar products.
2,188 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SokiGuo-MSFT 18,901 Reputation points Microsoft Vendor

    Hi @Santosh Subramanian

    Outlook has a Junk Email Filter that identifies messages that might be spam and moves them to the Junk folder. The Junk Email Filter evaluates each incoming message based on several factors. Junk email is also subject to the settings of the recipient client.

    You can add an email address or domain name to your safe senders list. Email addresses and domains on the safe senders list are not considered spam, regardless of the content of the message.

    Home>Junk E-mail Options...>Safe Senders>Add.

    User's image

    Hope this helps!

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments