Azure powershell function app missing function - function

Prasant Chettri 66 Reputation points
2023-11-01T06:44:30.79+00:00

Azure powershell function app missing function - function under function blade. I only see it proxy, app file etc and no function. Ive tried deploying on different subscription and test tenant, different app hosting tier and still the same

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,512 questions
0 comments No comments
{count} votes

Accepted answer
  1. MayankBargali-MSFT 69,931 Reputation points
    2023-11-01T11:49:39.2966667+00:00

    @Prasant Chettri Thanks for reaching out.

    There could be several reasons that you are not able to see the function in the azure portal.

    • When you have deployed your function did you see successfully message, or do you see any error/exceptions?
    • The function input/output binding is incorrect. Have you tried to run your function locally before deploying to azure? Did you see your functions in the local environment?
    • Trigger sync issue where you may need to sync the trigger again using this API and see if it helps you.

    I will also suggest to validate the application insights logs to see if there are any runtime exception/errors in your function app which would be causing this issue. You can also review the diagnose and solve problem on your function app to know more details.

    I will also suggest you to review the Functions PowerShell developer guide.

    0 comments No comments

0 additional answers

Sort by: Most helpful