RE: Update your API Management API version to 2021-08-01 or later, resource has no higher version Microsoft.ServiceFabric/clusters/applications

Djuradj Kurepa 20 Reputation points Microsoft Employee
2023-11-06T11:35:39.9833333+00:00

Hello,

Recently my team and I got an email telling us that we need to update our deployment scripts to use version 2021-08-01 or later. The issue is, we're on the latest version for the resources we're using: Microsoft.ServiceFabric/clusters/applicationTypes@2021-06-01, Microsoft.ServiceFabric/clusters/applicationTypes/versions@2021-06-01 and Microsoft.ServiceFabric/clusters/applications@2021-06-01 (https://github.com/dotnet/arcade-services/blob/main/eng/deployment/app.bicep). Could you advise us on what we should do? Will we need to migrate onto something new?

Also, could you give us a timeframe on when this old API is going to be deprecated? The email said 30th September 2023, but it appears that hasn't happened yet.

Thanks

Azure API Management
Azure API Management
An Azure service that provides a hybrid, multi-cloud management platform for APIs.
1,852 questions
Azure Service Fabric
Azure Service Fabric
An Azure service that is used to develop microservices and orchestrate containers on Windows and Linux.
253 questions
0 comments No comments
{count} votes

Accepted answer
  1. MuthuKumaranMurugaachari-MSFT 22,256 Reputation points
    2023-11-06T14:56:06.2+00:00

    Djuradj Kurepa Thanks for posting your question in Microsoft Q&A. The breaking change notification is related to Azure API Management and more about this change is published in API version retirements (September 2023) doc. However, this is not retired yet with similar discussion happening in other thread. I will post the latest update on that once we have more info. Please follow required action to move towards the latest API version in your ARM or bicep templates/tools/scripts for API Management.

    With that said, this change will not impact other resources such as Microsoft.ServiceFabric and will continue to work as expected.

    Sorry about the confusion caused by this. I hope this helps and let me know if any other questions.


    If you found the answer to your question helpful, please take a moment to mark it as Yes for others to benefit from your experience. Or simply add a comment tagging me and would be happy to answer your questions.

    1 person found this answer helpful.
    0 comments No comments

0 additional answers

Sort by: Most helpful