When I share documents on sharepoint, to guest usera, the can't open the link anymore

Micha Bucher 0 Reputation points
2023-11-15T14:08:17.5866667+00:00

I've registered sharepoint users, when I share links with documents to share with the user they can't open this link.

Message: this link is only available for internal users

The access to the sharepoint works fine for them.

Have checked the users in Azure on looks fine too, users are registered as guest.

Many thanks in advance

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
10,037 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Emily Du-MSFT 43,176 Reputation points Microsoft Vendor
    2023-11-16T07:13:46.4066667+00:00

    Please check below tips to troubleshoot the issue.

    1.Enable external sharing in the tenant level. Go to SharePoint admin center -> Polices -> Sharing -> Set Anyone, New and existing guests or Existing guests only for both SharePoint and OneDrive.

    2.Enable external sharing in the tenant site level. Go to SharePoint admin center -> Sites -> Active sites -> Select the site -> Sharing -> Set Anyone, New and existing guests or Existing guests only.

    3.Go the site collection which documents stored in -> Site settings -> Site collection features -> Deactivate Limited-access user permission lockdown mode feature.

    4.When you share a document, select the file -> Share -> Settings gear icon -> Check the link type. It should be chosen Anyone, People with existing access or People you choose.

    1

    2


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.