Task Scheduler - cannot edit any tasks (error 2147750680)

Georgi Iovchev 0 Reputation points

Hi, I am having very strange issue with Task Scheduler.
I can create run or delete scheduled stasks, but I cannot edit them.
Whatever edit to a task (my task) results in error 2147750680.
For example, change only the description.
Screenshot 2023-11-16 215555

I get same error also when I try to import task (xml). I tried also with powershell, but there I got other error which I don't understand.Screenshot 2023-11-16 220544

Set-ScheduledTask : The task XML contains a value which is incorrectly formatted or out of range. 
At line:1 char:9 
+ $task | Set-ScheduledTask 
+         ~~~~~~~~~~~~~~~~~ 
    + CategoryInfo          : NotSpecified: (PS_ScheduledTask:Root/Microsoft/...S_ScheduledTask) [Set-ScheduledTask], 
    + FullyQualifiedErrorId : HRESULT 0x80041318,Set-ScheduledTask

My user have admin privileges. But even if I run Task scheduler or powershell as admin, I get the same issue. As a workaround, I can delete the task and recreate it from scratch with whatever settings I need, but that is not very convenient.

I am running Windows 11 23H2 22631.2506, that was recently upgraded from 11 22H2. Before the upgrade, I think task scheduler was working fine. I have also another machine with same windows 11, but there is no such problem with task scheduler.

Need help to fix this issue without reinstalling my machine.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
6,813 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. MotoX80 29,371 Reputation points

    2147750680 is 0x80041318.

    I found this post.


    Based on that, you can try updating the account that the task runs as. Next I would suggest making a trivial change to the tasks trigger. Maybe modify the "Stop task if it runs longer than" setting.

    Is your trigger set to repeat?

    If that doesn't work, then open a command prompt with Run as Administrator and "cd C:\Windows\System32\Tasks". Then open a task file with notepad. Do you see the MaintenanceSettings that the post described?

    Maybe post one of the tasks XML back here and see if any user can see something.

    0 comments No comments

  2. Georgi Iovchev 0 Reputation points

    I tried to reply as comment thousand times but for some reason it does not get saved. Last try and I give up.

    What I was trying to say is that if I change the user to be someone else (or create it initially to run with another account - SYSTEM for example) then I can edit everything in the task. So the problem is only if the task is to run as my user.