Visual Studio Community 2022 won't launch (Could not start visual studio due to an error. StreamJsonRpc.RemotelnvocationException: Configuration system failed to initialize (Errorkind: Error Result: 80131500))

Yahtzee Hearth 0 Reputation points

This problem began when I tried to launch VS Community after shutting off my PC the previous night. VS Would launch and then use a lot of power (as seen on task manager) then crash. I tried repairing the installation twice, reinstalling, booting in safe mode, and other debugging methods (including renaming and deleting the contents of C:\Users<user>\AppData\Local\Microsoft\VSCommon\OnlineLicensing) but to no avail. Now unlike when this problem began VS won't even launch in the first place, giving an error (pic attached). I have attatched the most recent log file generated: ActivityLog.xml. My guess is that some file(s) corrupted because I didn't close VS before shutting off my pc. Doing devenv.exe /resetsettings makes it run for a second before ultimately crashing, just as it did this afternoon when I first noticed the issueUser's image

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,086 questions
Visual Studio Debugging
Visual Studio Debugging
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Debugging: The act or process of detecting, locating, and correcting logical or syntactical errors in a program or malfunctions in hardware. In hardware contexts, the term troubleshoot is the term more frequently used, especially if the problem is major.
878 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Anna Xiu-MSFT 20,331 Reputation points Microsoft Vendor

    Hi @Yahtzee Hearth ,

    Welcome to Microsoft Q&A! 

    Could you find the CommonExtensions, Extensions and PrivateAssemblies folders under the path: d:\program files\vs\common7\ide?

    If you can find them, please try to rename these folders, and repair your VS in Visual Studio Installer to check it again. 

    If it doesn’t work, I recommend you do a clean uninstallation and retry the installation:

    1. Manually delete any leftover install and cache folder you previously installed to:

    %ProgramFiles(x86)%\Microsoft Visual Studio


    %ProgramFiles%\Microsoft Visual Studio

    1. Delete the setup registry key (Please backup.), which was set when you first installed (Maybe there is only one key, please check one by one.):




    1. Download the new bootstrapper file from and run it as administrator. 



    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.