Enable guest access for Windows Server 2022

Андрей Михалевский 2,846 Reputation points
2023-11-24T16:56:30.1966667+00:00

Hello. I have a Windows server 2022 server not included in an Active Directory domain.

I need everyone to be able to access its network folder without entering a login password.

Windows 7-11, Windows Server 2012-2019 clients can log in to the folder.

Windows Server 2022 client cannot log on to the folder.

Debug with wireshark:

22133 179.405798 10.2.23.222 10.2.111.6 SMB2 339 Session Setup Response, Error: STATUS_MORE_PROCESSING_REQUIRED, NTLMSSP_CHALLENGE

If I enable the policy on the client: Enable insecure guest logons

I can log in after that.

Q: What to configure on Windows Server 2022 so that another computer with the same operating system can log into a folder ? I can't edit the client registry

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,616 questions
0 comments No comments
{count} votes

Accepted answer
  1. Wesley Li 6,755 Reputation points
    2023-12-29T07:01:46.51+00:00

    Hello

    To allow another computer with the same operating system (Windows Server 2022) to log into a folder without entering a login password, you can try the following steps on the server:

    Open the Local Group Policy Editor console (gpedit.msc) and navigate to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options.

    Enable the following settings:

    Accounts: Guest Account Status: Enabled

    Network access: Let Everyone permissions apply to anonymous users: Enabled

    Network access: Do not allow anonymous enumeration of SAM accounts and shares: Disabled

    Open the Deny log on locally policy under Local Policies -> User Rights Assignment to ensure that the Guest account is specified in the policy settings.

    Make sure that Guest or Everyone is also specified in the Access this computer from network policy and the Deny access to this computer from the network policy should not have Guest as the value.

    Also, make sure that network folder sharing is enabled under Settings -> Network & Internet -> Ethernet -> Change advanced sharing options. Check that Turn on file and printer sharing, Network Discovery (allows to show computers in the network environment) are enabled, and Turn off password protected sharing option is disabled in all network profile sections (Private, Public, All networks).

    Please note that opening anonymous access to shared network folders is not recommended for security reasons. Anonymous access allows any unauthenticated user to read, modify, or delete files in a shared folder. Therefore, it’s recommended for exceptional use in a secure network perimeter.

    0 comments No comments

0 additional answers

Sort by: Most helpful