Issue in getting connecting from IoT Edge Device to IoTHub even after the Ubuntu machine is in online

Athira Gopinath(UST,IN) 96 Reputation points
2023-11-27T05:31:58.92+00:00

Hi Team,

As part of our research, we are using IoT Edge Device to send real time data. Considering RPI or Ubuntu machine as IoT Edge Device ,personal hotspot (mobile network) is used for connecting the Edge device to IoTHub. Certain times, we observed that the IoT Edge device is not connecting to IoTHub even after the Ubuntu or RPI is in online(browse the internet, ping google from terminal).IoT Edge Device is showing as offline from Azure Portal, not receiving any data at IoTHub.

Please provide a solution for the issue discussed as this urgent issue to be solved

Azure IoT Edge
Azure IoT Edge
An Azure service that is used to deploy cloud workloads to run on internet of things (IoT) edge devices via standard containers.
561 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Sander van de Velde | MVP 31,211 Reputation points MVP
    2023-11-27T07:49:59.9466667+00:00

    Hello @Athira Gopinath(UST,IN) ,

    Azure IoT Edge can run forever if it's made production ready.

    Have you put some time in the production checklist?

    Think about:

    • rolling logs
    • routing TLS cert expiration (that development cert)
    • protocol selection (mqtt, amqp or a websockets variant)
    • host storage location
    • etc.

    Personally, I use the RPI only for development and testing. Production is done on a regular Industrial PC.

    Next check the logs of the edgeHub for possible information about the connection errors.


    If the response helped, do "Accept Answer". If it doesn't work, please let us know the progress. All community members with similar issues will benefit by doing so. Your contribution is highly appreciated.