Problem with DNS resolution of DC name - DOTMATRIX ltd. Sofia, Bulgaria

Pavel Yanev 20 Reputation points
2023-11-29T09:16:59.0633333+00:00

Hello gents,

I've encountered a problem since a couple of days that might be simple, but I stuck. So please accept my apologies for wasting your time, but I'll appreciate any help.
I have a very small home-office network with a domain controller and active directory built on Server 2022. 3-4 OUs and up to 5 users - I'm using it primarily to control the app access and web filtering. Everything worked smoothly until this Monday, when I found out that GPOs are not applying anywhere - neither users nor computers. GPUPDATE /FORCE outputs a fail due to inability to resolve the name of the DC ( in my case 'dotmatrix.local'). From a workstation I can ping the server hostname but cannot ping the DC hostname (see scrshots). My router is configured to assign the DC IP address for a DNS over DHCP, since the beginning and it worked fine since the problem occurrence.

Screenshots location: https://1drv.ms/f/s!AstkAgGfsc2javncTpTOSvBJErU?e=ppq47l

Thanks in advance, everyone!

RGDS, Pavel

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,611 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,225 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anonymous
    2023-11-29T19:05:39.9466667+00:00

    I just took a look and see that your domain controller AP44DC 192.168.50.241 uses the router for DNS. Domain controller and all domain members must use the static ip address of DC listed for DNS and no others such as router or public DNS. I stopped looking here because this one is a showstopper. Also there appears to be an IPv6 DHCP server on the network (most likely the router) that will be problematic for your domain if not configured correctly. The simplest solution here is to turn off the IPv6 DHCP server within router config. If problems persist then put up a new set of files to look at.

    --please don't forget to close up the thread here by marking answer if the reply is helpful--

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Anonymous
    2023-11-29T13:32:11.0466667+00:00

    Please run;

    Dcdiag /v /c /d /e /s:%computername% >C:\dcdiag.log (run on PDC emulator)
    repadmin /showrepl >C:\repl.txt (run on any domain controller)
    ipconfig /all > C:\%computername%.txt (run on EVERY domain controller)
    ipconfig /all > C:\problemworkstation.txt (run on problem pc)

    Also check the domain controller System and Replication (DFS or FRS) event logs for errors since last boot. Post the Event Source and Event IDs of any found. (no evtx files)

    then put unzipped text files up on OneDrive and share a link.


  2. Pavel Yanev 20 Reputation points
    2023-11-30T08:09:38.33+00:00

    Thank you, Dave.
    I'll apply the changes mentioned above to the DC's IP configuration a bit later today, and I'll close the thread.
    For the IPv6 config, It's a hell, as the router I'm using (TP-LINK Omada ER605 v2) does not have configuread IPv6 at all, and still broadcasts IPv6 addressess. :( But this topic is not for here, so again- thank you and wish ya all the best.

    RGDS, Pavel


  3. Pavel Yanev 20 Reputation points
    2023-12-01T11:07:51.79+00:00

    It completely worked out. Marked the answer as accepted.

    All the best: Pavel