Problem switching from Visual Studio subscription plan to pay-as-you-go

Amirreza Niakanlahiji 0 Reputation points
2023-12-04T21:55:31.5566667+00:00

I am not able to switch my Visual Studio subscription plan to pay-as-you go as I am getting

Screenshot 2023-12-04 at 1.50.25 PM

I am also not able to move my resources from this subscription to another pay-as-you-go subscription that I have just created as I am getting this

The subscription '[Visual Studio subscription ID]' is disabled and therefore marked as read only. You cannot perform any write actions on this subscription until it is re-enabled. (Code: ReadOnlyDisabledSubscription) (Code: ReadOnlyDisabledSubscription)

Any suggestion how I can fix this

Azure Cost Management
Azure Cost Management
A Microsoft offering that enables tracking of cloud usage and expenditures for Azure and other cloud providers.
2,334 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Monalla-MSFT 12,846 Reputation points
    2023-12-05T20:52:00.9133333+00:00

    @Amirreza Niakanlahiji - Welcome to Microsoft Q&A and thanks for reaching out to us.

    You might not see the Switch Offer option if:

    • If you are still in your first billing period, so please verify that you have completed your first billing period. If you have not completed your first billing period, you will need to wait until it is completed before you can switch offers.
    • You don't have a subscription with pay-as-you-go rates. Currently only subscriptions with pay-as-you-go rates can be converted to another offer.

    Please take a look at the below doc for more reference: https://learn.microsoft.com/en-us/azure/cost-management-billing/manage/switch-azure-offer

    For the 2nd issue, please ensure the subscriptions are enabled and then try to move resources.

    Hope this helps. and please feel free to reach out if you have any further questions.


    If the above response was helpful, please feel free to "Accept as Answer" and click "Yes" so it can be beneficial to the community.

    0 comments No comments