Azure Open AI Service DALL·E text to image Your task failed as a result of our safety system.

vinish george 2 Reputation points
2023-12-05T05:18:15.1+00:00

Hi,

When using the Azure OpenAI Service DALL-E for text to image generation with default content filter settings, we receive an error for a specific text prompt, but the same prompt works when retried. Our expected behavior is that it fails consistently for security reasons. The error message indicates that the task failed as a result of the safety system. Can someone provide insight into why this is happening and how to prevent it?

Below is an example of a prompt that generates an error and another that is successful.

Example:

We get an error

User's image

for the text entered For Example :

"

Create an image that showcases a diverse range of handicraft items made from different materials. The art style could be 'vintage illustration from the 1950s,' with a nostalgic and retro feel. Use warm and earthy colors to complement the materials. Include directive details, such as 'arrange the items in an organized and visually appealing manner,' and use adjectives to describe the materials, such as 'soft and vibrant fabric,' 'moldable and textured clay,' and 'smooth and polished wood.' Ensure image quality settings are: Hyper Detail, 8K, HD, Octane Rendering, Unreal Engine, V-Ray, full hd -- s5000 --uplight --q 3 --stop 80--w 0.5 --ar 1:3.

"

But the same prompt when retried generates the image too .

successful generated image

Expected

It should fail consistently for the security reasons.

Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,627 questions
{count} votes

1 answer

Sort by: Most helpful
  1. AshokPeddakotla-MSFT 30,321 Reputation points
    2023-12-15T03:06:48.4266667+00:00

    vinish george Apologies for the delayed response.

    I have been checking on this issue and tried multiple times but unable to reproduce the same.

    As you can see in the below, I'm getting the error everytime I run the prompt for generating the image.
    User's image

    openai

    Could you try deleting the generated images once and see if that works? You can also try to rephrase your prompts to make them less likely to trigger the content filter system.

    Is there any update on the issue ? we are getting a lot of safety system error for simple statements

    Could you share more details?

    0 comments No comments