Need Help with 'MountVol' Command

JamesBacon 0 Reputation points
2023-12-06T00:00:01.6866667+00:00

I wanted to check EFI with mountvol, which I do regularly; however, this time, I had a minor screw up and now I can't tell if I've definitely unmounted the drive

I typed "mountvol e: /s" into CMD, then I typed "dir e:\efi\microsoft\boot\*.efi", but instead of listing the boot files, it said "cannot find the file specified"

this is odd because I'm certain I mounted the E drive successfully, as there was no "cannot find the file pathway specified" when inputting the mountvol command.

I checked with my Windows 11 device and found that failing to type 'dir' will return that message but it's too late to check what exactly I might have messed up in the command. after that, I retyped the command and it worked just fine

I then typed "mountvol e: /d" which didn't return any message. to make sure it was unmounted, I typed e: /d again, and it said "cannot find the file specified" which is good

I've since restarted but I'm just unsure if I actually mounted the E drive originally or some other drive, and why it returned the "cannot find the file specified" to my 'dir' command

I've done the "e: /d" command again to the E drive, and even some keys near 'E' like 'r', 'w', and 'd'; they all returned the "cannot find file specified" message which means they aren't mounted

MAIN QUESTIONS: is it possible to use mountvol /s twice on the same pathway on Windows 10, and can you mount the EFI drive to 2 different pathways with /s at the same time

I tried on my Windows 11 laptop, and trying to use "mountvol e: /s" twice returned the message "directory is not empty".

typing "e: /s" and then trying to mount to another pathway (mountvol r: /s for example), returned the message "parameter is incorrect". once I unmounted from "E", the mountvol r: /s command worked

is this the same on Windows 10? I just can't put my mind at ease over whether or not I actually did mount EFI to 'E' and unmounted it successfully. nor do I understand why it returned the "cannot find file specified" message

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
11,117 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 33,941 Reputation points Microsoft Vendor
    2023-12-06T05:14:55.5433333+00:00

    Hi,

    You can only mount the EFI system partition to one empty directory with mountvol. If the EFI system partition is already mounted to a drive, it cannot be mounted again because the drive is already in use. If you want to mount it again, you need to remove the mount from the directory with the /d parameter first or you will see the error "the directory is not empty".

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments