My Windows10/11 can't connect to any server using OpenSSH

Rosh Alcatraz 0 Reputation points
2024-01-19T03:50:25.6433333+00:00

At first I tried to connect to my Ubuntu virtual machine using openssh, but it failed, so I started troubleshooting:

1.I thought it was a Windows 10 problem at first, so I upgraded to Windows 11 and the problem still persists.

2.The firewall configuration of my Windows and Ubuntu virtual machines is correct(I even tried to disable all off them).

3.The VM server is running properly, I was able to successfully connect to the SSH server using software such as XShell, PuTTY, and MobaXterm.

4.I tried to reset the network using "netsh winsock reset" and "netsh int ip reset" commands, but it still didn't work.

5.The server supports password login and does not require certificate authentication, so maybe the certificate is not the problem.And I have read and write access to the certificate file.

6.I used openssh to connect to the web server that tested SSH, still connection failed. Other applications can still connect successfully.

The openssh debugging information is as follows: 1

It only has the error message "Permission denied", unlike other errors where the reason is noted in parentheses.

After looking up the information, I found that it was still in the setting up of TCP, and at this stage it failed (if I understand correctly).

The following picture is what happened when I connected to the web server used to test SSH : 2

The server domain name is: tty.sdf.org

I can't successfully connect to either server using openssh, but I was able to connect with any other app.

With all that said, I'm pretty sure the problem is on Windows (Windows 10 and Windows 11), but I'm not sure what is preventing openSSH from connecting to the server.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,207 questions
Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,626 questions
0 comments No comments
{count} votes