SharePoint Server 2019 Search. Administrative status The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

Rahim Molvani 1 Reputation point
2024-01-19T11:23:22.7+00:00

SSL certificates got renewed and applied on our all SharePoint Server 2019 sites. All sites are working fine. Getting bellow error in SharePoint Server 2019 search. Error in Logs. An operation failed because the following certificate has validation errors: Errors: SSL policy errors have been encountered. Kindly help to resolve this issue and will be grateful. User's image

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,156 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Ling Zhou_MSFT 11,775 Reputation points Microsoft Vendor
    2024-01-22T08:37:25.96+00:00

    Hi @Rahim Molvani,

    Thank you for posting in this community.

    Since we can't reproduce your situation, we need to narrow down the problem and try some things.

    1.The error you encountered is documented in this article, which you can refer to see if it solves your problem: Could not establish trust relationship for SSL/TLS secure channel.

    2.Please try restarting the IIS service and then restarting the search service.

    3.Try to use a different browser or your browser's InPrivate mode to see if the same error occurs.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Ling Zhou_MSFT 11,775 Reputation points Microsoft Vendor
    2024-01-26T09:20:19.04+00:00

    Hi @Rahim Molvani,

    Thank you for posting in this community.

    I have come across people in the forums with similar problems to the one you are experiencing. He solved his problem by removing the SSL certificate. You can try if this method also solves your problem.

    1.Open IIS >find SharePoint Server >Open Server Certificates. Remove your SSL certificate.

    User's image

    2.You can either re-add your SSL certificate or refer to this article to recreate an SSL certificate. How to Set Up SSL on IIS 7 or later


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.