Web Redirect URI Error

Nearly New Crew 0 Reputation points
2024-01-24T11:56:57.3033333+00:00

Hi On my wordpress site the YaySMTP authorised Redirect URI is stated as https://nearlynewcrew.com/wp-admin/admin.php?page=yaysmtp But I am getting this error when authorising the connection Request Id: cd0a9e36-5510-48b8-b713-7a721fabab00 Correlation Id: d0e09237-7b86-4f78-a905-8142e06970e5 Timestamp: 2024-01-24T11:16:43Z Message: AADSTS50011: The redirect URI 'https://nearlynewcrew.com/wp-admin/options-general.php' specified in the request does not match the redirect URIs configured for the application 'be8d9a7b-5d8a-47e8-aed1-f852d8ee6fe2'. Make sure the redirect URI sent in the request matches one added to your application in the Azure portal. Navigate to https://aka.ms/redirectUriMismatchError to learn more about how to fix this. This is in the Web redirect on Azure. Please can you help as I cannot see why they do not match? Thanks in advance. Regards Steve

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,496 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Grmacjon-MSFT 13,961 Reputation points
    2024-02-21T17:10:41.02+00:00

    Hi @Nearly New Crew
    As Amberg mentioned in his comment, the error message you’re seeing is due to a mismatch between the redirect URI specified in your request and the one configured for your application in the Azure portal. The redirect URI in your request is ‘https://nearlynewcrew.com/wp-admin/options-general.php’, but the authorized redirect URI for your YaySMTP plugin on your WordPress site is ‘https://nearlynewcrew.com/wp-admin/admin.php?page=yaysmtp’. Here’s are some detailed steps to help you fix this:

    1. Go to the Azure portal and sign in with your account.
    2. In the left-hand menu, click on “Azure Active Directory”, then select “App registrations”.
    3. Find and select your application (with the ID ‘be8d9a7b-5d8a-47e8-aed1-f852d8ee6fe2’) in the list.
    4. In your application’s page, click on “Authentication”. Under the “Redirect URIs” section, update the URI to match the one specified in your YaySMTP settings (‘https://nearlynewcrew.com/wp-admin/admin.php?page=yaysmtp’).
    5. Click on “Save” at the top of the page to apply the changes.

    After updating the redirect URI in the Azure portal, try authorizing the connection again on your WordPress site. If you’re still encountering issues, please let me know! Best, -Grace

    0 comments No comments