New Teams is displaying default time zone as UTC when setting up a meeting through Teams‎

Bajracharya, Prabinesh 392 Reputation points
2024-01-24T17:50:27.7166667+00:00

New Teams is displaying the default time zone as UTC when setting up a meeting in Teams. This is causing issues for users because if they don't convert it manually before sending the meeting invite, the meeting is set to the wrong time, leading to confusion. We have attempted to resolve this issue by clearing the New Teams cache, clearing Edge and Chrome cache, restarting the machine, checking the default time zone in Microsoft 365, and ensuring Teams is updated to the latest available version. However, none of these measures have successfully fixed the problem for some users.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
8,670 questions
{count} votes

7 answers

Sort by: Most helpful
  1. Ran Hou-MSFT 6,925 Reputation points Microsoft Vendor
    2024-01-25T05:50:40.0133333+00:00

    Hi @Bajracharya, Prabinesh Based on our research, the behavior is a result of Teams' design and there is currently no way to change it. So you need to change it manually when editing the meeting information. Meanwhile, to get this feature more quickly, we recommend you give the feedback in Teams UserVoice. Many features of our current products are designed and upgraded based on customers’ feedback. With requirements like this increase, the problem may well be released in the future.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


    2 people found this answer helpful.

  2. Nikoli 10 Reputation points
    2024-02-08T03:19:52.4766667+00:00

    See if repairing and resetting the New Teams helps?
    Apps & Features - Microsoft Teams - Advanced Options.

    Worst case also uninstall the old version too.

    2 people found this answer helpful.

  3. Kyriakos Tsourapas 10 Reputation points
    2024-02-21T16:28:11.68+00:00
    2 people found this answer helpful.
    0 comments No comments

  4. Harri Helokangas 10 Reputation points
    2024-02-22T11:59:19.8533333+00:00

    I think Microsoft needs to check why the setting is not being applied correctly, but you can fix this issue by:

    1. Go to Outlook for the web General settings
    2. Set the Time zone again, even if it is correct
    3. Sign out of Teams and back again

    You need to "touch" the setting and save it again so that it is applied in new Teams

    2 people found this answer helpful.

  5. NP 366 Reputation points
    2024-02-14T04:18:00.4933333+00:00

    we have the issue as well. Seems to be sporadic. Hopefully there is a proper fix