How disable Windows 11 Start Menu from opening at first user logon

Stijn Denruyter 0 Reputation points
2024-01-25T20:49:19.5733333+00:00

I'm using OSDCloud to automatically install a clean Windows 11 image. In my unattend.xml, I'm doing an auto logon after the OOBE phase to display a form where our helpdesk has to select something. Unfortunately, Windows 11 automatically opens the Start Menu and the form is behind that Start Menu and is not visible until you close the Start Menu. I want to avoid the Start Menu from opening at first user logon.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,622 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Hania Lian (Shanghai Wicresoft Co,.Ltd.) 5,826 Reputation points Microsoft Vendor
    2024-01-29T07:31:36.14+00:00

    Hello, To prevent the Start Menu from automatically opening on first user login, you can modify the Windows Registry to disable the “First Logon Animation”. Here’s how: Open the Registry Editor. To do this, press Win + R to open the Run dialog box, then type regedit and press Enter. Navigate to this key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon Look for the EnableFirstLogonAnimation key. If it doesn’t exist, right-click on the right pane, select New > DWORD (32-bit) Value, and name it EnableFirstLogonAnimation. Double-click on EnableFirstLogonAnimation key and set its value to 0 to disable the first logon animation (which includes opening the Start Menu). Close the Registry Editor and restart your computer to apply the changes. Please note: Modifying the Windows Registry can cause serious problems if not done correctly. Always backup your data and/or the Registry before making changes. If you want to apply this setting in your unattend.xml, you can add the following lines under the appropriate configuration pass (for example, specialize or oobeSystem): <settings pass="oobeSystem"> <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> <FirstLogonCommands> <SynchronousCommand wcm:action="add"> <CommandLine>reg add HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon /v EnableFirstLogonAnimation /t REG_DWORD /d 0 /f</CommandLine> <Description>Disable first logon animation</Description> <Order>1</Order> </SynchronousCommand> </FirstLogonCommands> </component> </settings> This script will run a command to modify the Windows Registry during the OOBE phase, effectively disabling the first logon animation. Best Regards, Hania Lian

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments

  2. Stijn Denruyter 0 Reputation points
    2024-01-30T09:40:46.82+00:00

    Thank you for the feedback. However, the solution did not work for me. After doing some extra research, I found this:

    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced" /v StartShownOnUpgrade /t REG_DWORD /d 1 /f
    

    After adding this to my unattend.xml file in the FirstLogonCommands section, the Start Menu did not open anymore. No need to add this to the Default User registry hive as this will be injected in the registry before the logon.

    0 comments No comments