Cannot monitor created resource in Azure

BerkLee 0 Reputation points
2024-01-26T10:07:41.9033333+00:00

I created an Azure resource for Power BI Embedded. It works and my workspace is able to connect to it. However when attempting to monitor, I cannot select a metric. It says "We are not able to retrieve these values at this time". When I opened my dev console, it says that the resource is missing/cannot be found. 404. But, it's clearly there, and its clearly being used. What's going on??? azure404.png Troubleshooting that I've done was check and find out that my subscription didn't have Microsoft.Insights as a resource provider. I only just registered it but I'm still getting the same error. I'm also an Owner of the resource so I don't think it's a rights issue.
Suggestions?

Azure Monitor
Azure Monitor
An Azure service that is used to collect, analyze, and act on telemetry data from Azure and on-premises environments.
2,679 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. BerkLee 0 Reputation points
    2024-01-26T10:16:57.74+00:00

    Well this is embarassing. It turned out to actually be the Resource provider microsft.insights. It works now.

    0 comments No comments

  2. tbgangav-MSFT 10,236 Reputation points
    2024-01-27T04:20:24.8666667+00:00

    Hi @BerkLee , Glad to know that it works now. Yes, typically it takes some time to complete the registration; especially for the resource providers like microsft.insights.

    0 comments No comments