Set Microsoft Edge as default browser

Iswarya 0 Reputation points
2024-01-29T22:03:14.42+00:00

I have same problem in changing default browser to Microsoft Edge from IE. But, the improvement in my case is, I can change the default browser from Settings--> Default Apps--> Browser (which works perfectly). But practically it is not changing when I run below commands in Powershell in Admin mode. Set-ItemProperty -Path "HKCU:\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\http\UserChoice" -Name "ProgId" -Value "MSEdgeHTML" Set-ItemProperty -Path "HKCU:\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\https\UserChoice" -Name "ProgId" -Value "MSEdgeHTML" It changes to MSEdge but after 1 minutes, it defaults back to IE. If the change is not accepted, it should not happen when doing manually right? Can someone guide me on this?

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,326 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Ian Xue (Shanghai Wicresoft Co., Ltd.) 27,266 Reputation points Microsoft Vendor
    2024-01-30T04:52:32.4866667+00:00

    Hi Iswarya,

    I don't think changing the ProgId value works anymore in Windows Server 2019 because you have to change the Hash value which is used to protect ProgId as well. However Microsoft has not disclosed how to generate the hash. This makes the default application can only be changed in GUI and ensures it's done by the user.

    Best Regards,

    Ian Xue


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments