credentials for newly created user to azure vm do not work

Arunkumar Venkatesan 60 Reputation points
2024-02-02T09:50:38.4833333+00:00

I have created a new microsoft entra acount. And I have assigned a reader role for that account on my Azure vm. But my credentials are not working when I try to connect to the VM. Please assist.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,789 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Timmy Malmgren 581 Reputation points
    2024-02-02T11:00:09.2366667+00:00

    Hi

    Are you trying to connect by logging into the machine through for example RDP? in Azure there are two different "layers" for security rights, the "control plane", easiest described as the things you se in your azure portal (simplified ofc :) ) and the "data plane", easiest described as the "inside" of your resources. For example the operating system of a VM. These two layers do not interchange automaticly and to use Entra ID with a VM you have to enable this "Login with azure AD"

    To create a Windows Server 2019 Datacenter VM in Azure with Microsoft Entra login:

    1. Sign in to the Azure portal by using an account that has access to create VMs, and select + Create a resource.
    2. In the Search the Marketplace search bar, type Windows Server.
    3. Select Windows Server, and then choose Windows Server 2019 Datacenter from the Select a software plan dropdown list.
    4. Select Create.
    5. On the Management tab, select the Login with Microsoft Entra ID checkbox in the Microsoft Entra ID section. Screenshot that shows the Management tab on the Azure portal page for creating a virtual machine.
    6. Make sure that System assigned managed identity in the Identity section is selected. This action should happen automatically after you enable login with Microsoft Entra ID.
    7. Go through the rest of the experience of creating a virtual machine. You have to create an administrator username and password for the VM.*

    If you however just want access the the virtual machine without Entra ID you can go to the VM in Azure portal and select "reset password" in the left pane and update the password for a local user account.

    User's image

    Hope you find this helpful :)

    Best Regards,

    Timmy Malmgren

    ---If the Answer is helpful, please click "Accept Answer" and upvote it as it helps others

    1 person found this answer helpful.