ROBOCOPY NOT WORKING WINDOWS 11

Lars Kornbrink 20 Reputation points
2024-02-04T20:14:19.0766667+00:00

New to me (used) computer, running W11. I can not get Robocopy to work. On my previous PC it worked fine using the following commands: robocopy C:\Users\Lars\Documents E:\Documents /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy C:\Users\Lars\Pictures E:\Pictures /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy C:\Users\Lars\Music E:\Music /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy C:\Users\Lars\Videos E:\Videos /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt I have tried to use the same, with adjustments made for different drives. On the new computer, I use the C drive strictly for W11 OS, and all data files I wish to copy to external drive F, are on internal 2nd D drive. So, I used my old commands that worked, but changed the drives per below. I also saved the commands as a bat file and right click and run it as administrator. But nothing seems to happen: robocopy D:\Users\Lars\Documents F:\Documents /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy D:\Users\Lars\Pictures F:\Pictures /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy D:\Users\Lars\Music F:\Music /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt robocopy D:\Users\Lars\Videos F:\Videos /MIR /MT /R:5 /W:15 /NS /NC /NFL /NDL /NP /LOG+:\rlogs\log.txt One other difference is that the new computer has the following user info when I do CMD prompt: C:\Users\Superuser> I tried to changed the robocopy command to Users\Superuser, instead of Lars but still nothing.. Can anybody let me know what I need to adjust in the Robocopy commands to make it work? Thank you in advance.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
7,576 questions
0 comments No comments
{count} votes

Accepted answer
  1. MotoX80 30,826 Reputation points
    2024-02-04T20:32:55.46+00:00

    You're effectively disabling logging by using these switches.

    /NS :: No Size - don't log file sizes.
    /NC :: No Class - don't log file classes.
    /NFL :: No File List - don't log file names.
    /NDL :: No Directory List - don't log directory names.
    
    
    

    Remove those and run robocopy from a command prompt. Use /L to have robocopy just list what it intends to do without actually copying any files.

    Also remove the /LOG switch and let robocopy write to the console windows. Did you look in the rlogs folder (does it even exist?) at the log.txt file?

    Verify the source and destination are what you intend.


3 additional answers

Sort by: Most helpful
  1. Lars Kornbrink 20 Reputation points
    2024-02-04T22:15:50.15+00:00

    I see one member MotoX80 answered my question, but when I click on my / this thread - no answer shows! Anyone knows why that is? How can I view their answer?

    0 comments No comments

  2. Lars Kornbrink 20 Reputation points
    2024-02-04T22:35:41.3466667+00:00

    OK Thank you found our answer. I removed the switches per your recos. and ran with /L at the end. Nogo could not find path....Changed to Super user, still no go...see below not sure what is wrong in the path... robocopy D:\Users\Superuser\Documents F:\Documents /MIR /MT /R:5 /W:15 /L robocopy D:\Users\Superuser\Pictures F:\Pictures /MIR /MT /R:5 /W:15 /L robocopy D:\Users\Superuser\Music F:\Music /MIR /MT /R:5 /W:15 /L robocopy D:\Users\Superuser\Videos F:\Videos /MIR /MT /R:5 /W:15 /L This is the message I get back on all commands: The system cannot find the path specified. PS C:\Users\Superuser> robocopy D:\Users\Superuser\Music F:\Music /MIR /MT /R:5 /W:15 /L

    0 comments No comments

  3. Lars Kornbrink 20 Reputation points
    2024-02-05T21:05:13.2066667+00:00

    OK, it's working now - OMG finally. I did the directory search as you suggested , and the command that worked was to just cut out the user step etc: robocopy D:\Music F:\Music /MIR /MT /R:5 /W:15 That is what I used in CMD and it worked for all the directories. I guess maybe what confused the situation was that the directories to copy are not on the C drive with the OS, but on a second drive.. Either way it is now copying all my data correctly. Thank you so much for your help. :)

    0 comments No comments