Azure VM Standard NV18ads A10 v5 Linux (ubuntu 20.04) NVIDIA-SMI No Devices were found

Ryan Danzey 5 Reputation points
2024-02-08T00:03:48.7+00:00

Azure VM Standard NV18ads A10 v5 Linux (ubuntu 20.04) NVIDIA-SMI No Devices were found. The VM should see the GPU (NVIDIA A10) after following the steps listed in the following articles however currently I dont see the GPU.
NVIDIA Drivers install: https://learn.microsoft.com/en-us/azure/virtual-machines/linux/n-series-driver-setup NVIDIA GPU Driver Extension For Linux: https://learn.microsoft.com/en-us/azure/virtual-machines/extensions/hpccompute-gpu-linux The extension should be visible based on the following screen shot: User's image

lspci results: User's image

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,832 questions
0 comments No comments
{count} vote

1 answer

Sort by: Most helpful
  1. deherman-MSFT 31,996 Reputation points Microsoft Employee
    2024-02-08T19:09:02.47+00:00

    What version of the drivers got installed? Noted in the documentation: The Azure NVads A10 v5 VMs only support GRID 14.1(510.73) or higher driver versions. Please make sure you have installed the proper driver version and let us know if you still have issues.


    If you still have questions, please let us know in the "comments" and we would be happy to help you. Comment is the fastest way of notifying the experts. If the answer has been helpful, we appreciate hearing from you and would love to help others who may have the same question. Accepting answers helps increase visibility of this question for other members of the Microsoft Q&A community. Thank you for helping to improve Microsoft Q&A! User's image

    0 comments No comments