Error for a data copy activity in a pipeline within Microsoft Fabric - ZIP entry size is too large

Igor Muryjas 0 Reputation points
2024-02-10T21:58:50.63+00:00

I'm trying to import an XLSX file (with a size of about 300 MB) into a table using a pipline in Microsoft Fabric. There are 700k rows of data in the file. When I try to run the pipeline I get the below error. I tried to run it for the same file but with rows of data reduced to c. 1000 and it run just fine. This is the error I get when I run the pipeline for the original file:

ErrorCode=ExcelUnsupportedFormat,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=Only '.xls' and '.xlsx' format is supported in reading excel file while error is ' at NPOI.OpenXml4Net.Util.ZipInputStreamZipEntrySource.FakeZipEntry..ctor(ZipEntry entry, ZipInputStream inp)> at NPOI.OpenXml4Net.Util.ZipInputStreamZipEntrySource..ctor(ZipInputStream inp)> at NPOI.OpenXml4Net.OPC.ZipPackage..ctor(Stream filestream, PackageAccess access)> at NPOI.OpenXml4Net.OPC.OPCPackage.Open(Stream in1)> at NPOI.Util.PackageHelper.Open(Stream is1)> at NPOI.XSSF.UserModel.XSSFWorkbook..ctor(Stream is1)> at Microsoft.DataTransfer.ClientLibrary.ExcelUtility.GetExcelWorkbook(String fileExtension, TransferStream stream)'.,Source=Microsoft.DataTransfer.ClientLibrary,''Type=System.IO.IOException,Message=ZIP entry size is too large,Source=NPOI.OpenXml4Net,'

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
35,068 questions
{count} votes