i get an error that no vcpus are available when creating a container

David Shaff 20 Reputation points
2024-02-12T18:01:11.9933333+00:00

I created a couple basic container with 1 cpu and 8 and 16 gigs of ram. i then tried to create a third container of any size and i run into the error that the subscription quota has zero vcpus available and to extend the quota. However there are dozens of difference vcpu quotas and the error message doesn't specify which one. I also tried to free resources by deleting the 2 previous container completely and waiting a few days. however i still get the same error and can't even create a simple 1 vcpu 8 gig container any longer. the deletions were complete, no longer showing anywhere in the account btw. i checked available cpus for region and there are some available still. if a quota needs to be extended it is not clear which one or why deleting the previous containers didn't free up resources

Azure Container Instances
Azure Container Instances
An Azure service that provides customers with a serverless container experience.
608 questions
{count} votes

Accepted answer
  1. Sam Cogan 9,412 Reputation points MVP
    2024-02-13T16:13:35.6733333+00:00

    You are creating a spot container, so you need to up the quota for "Standard Spot Cores", in the region you require. Make sure you select "Azure Container Instances" from the provider drop downimage

    0 comments No comments

0 additional answers

Sort by: Most helpful