MFA worked on web application but not on xamarin application

Sharayu Mundhe 1 Reputation point
2020-03-19T08:41:54.347+00:00

Hi,
I have registered app on azure active directory for MFA, when web team used client id for MFA from web app MFA worked fine, but when we use same application from mobile then after otp verification it gives error as need admin approval. API permission in azure set as user.read(delegated permission). Why this happens as it worked fine on web, Is there is any specific things need to be implemented for mobile?

5041-mobmfaerror2.png

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,183 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. AmanpreetSingh-MSFT 56,466 Reputation points
    2020-03-19T10:31:30.103+00:00

    @Sharayu Mundhe , Based on the information you shared in the screenshot, I tried to track the request and confirmed that MFA was done successfully. The error occurs after MFA and it is for 'TestMFAMob2' app where admin consent is not provided. Could you please confirm if this is the same app you are using for web and mobile? I do not see any admin consent given to this app in our backend. Please try granting admin consent under API permissions section of this Application.

    -----------------------------------------------------------------------------------------------------------

    Please "Accept as answer" wherever the information provided helps you to help others in the community.

    0 comments No comments