Azure Active Directory - Invite email throws a 404!?!

Søren Alsbjerg Hørup 6 Reputation points
2020-03-20T10:47:33.377+00:00

Hi. We are currently experimenting with Azure Active Directory. Recently, when I try to add a user using the Invite external user feature, the recipient gets an email as usual, but the link returns a 404! I have tried multiple email addresses, but all invites I sent out fail. I get the attached 404 when pressing the https://login.microsoftonline.com/redeem?rd=******************** invite link. Is the service down? it worked in the past.

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,676 questions
No comments
1 vote

6 answers

Sort by: Most helpful
  1. soumi-MSFT 11,606 Reputation points Microsoft Employee
    2020-03-20T13:21:25.57+00:00

    @Søren Alsbjerg Hørup , I just did the test and it works fine for me. I added the user to my AAD Tenant as guest user and that user did receive the email from my tenant with the invitation. When clicked on the "Get Started" button, it takes me to the invitations' link and asks for the consent. Please refer to the screenshot below:

    5111-b2b.png

    I have not used that url https://b2b.azure.net/signup?tenant, before. But try the email way and I hope that works for you.

    Hope this helps.

    Do let us know if this helps and if there are any more queries around this, please do let us know so that we can help you further. Also, please do not forget to accept the response as Answer; if the above response helped in answering your query.

    No comments

  2. Søren Alsbjerg Hørup 6 Reputation points
    2020-03-20T13:39:39.337+00:00

    Hi!
    Thanks!

    I retested, the link i pasted was after i clicked it - meaning it was not the link in the email - i will update the post.
    If i copy the link directly from the get started email, i get this:
    https://login.microsoftonline.com/redeem?rd=********************

    If i click it, it throws a 404!

    I resendt the invitation, same story: 404!.

    I am very puzzled.

    No comments

  3. graham.burgsma 1 Reputation point
    2020-03-20T19:07:27.97+00:00

    I'm seeing the exact same issue, hope it gets resolved soon. Let me know if you find a solution!

    No comments

  4. Søren Alsbjerg Hørup 6 Reputation points
    2020-03-23T06:57:38.36+00:00

    Hi.

    I just retested today.
    I no longer get a 404, but i get a:
    Invitation redemption failed
    An error has occurred. Please retry again shortly.

    @graham.burgsma , do you still get a 404 or a redemption failed?

    No comments

  5. graham.burgsma 1 Reputation point
    2020-03-23T11:52:06.047+00:00

    Thanks for letting me know.

    I just tried again and the invitation worked for me, no issues this time! Maybe try resending your invitation?

    No comments