I am getting error "No quota is available to deploy this model version and deployment type." for GPT-4

ecaglar 0 Reputation points
2024-03-07T05:22:58.3633333+00:00

I am trying to deploy GPT-4 but getting the screenshot error. I have added "Cognitive Services OpenAI Contributor" role assignment to my "user" under Azure Open AI->Access control (IAM). Do you need to do anything else? Why am I getting this error? Do you have any idea? Thanks

User's image

User's image

Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
2,101 questions
{count} votes

1 answer

Sort by: Most helpful
  1. JananiRamesh-MSFT 20,826 Reputation points
    2024-03-07T10:06:56.7633333+00:00

    @ecaglar Thanks for reaching out. I tried to deploy gpt-4 model at my end and am able to reproduce the same error in East US region.

    Due to high demand, availability is limited in the East US region. If you're trying with East US region, as a workaround try deploying the service to another region like East Canada etc.. listed in the below table:

    or to increase the quota, you need to fill the below form and wait for the approval:

    https://aka.ms/oai/quotaincrease Additionally, there is no guarantee that your request will be approved for an application. User's image

    Hope this help! Do let me know incase of further queries, I would be happy to assist you.

    0 comments No comments