Error changing blob access tier to archive

Tim Dawson 0 Reputation points
2024-03-07T10:45:00.8433333+00:00

We've got a storage container with thousands of blobs, and after a period of time elapses we change the access tier of older blobs to archive. This has always worked for us until a few months ago, when we started getting 400 errors back:

Blob access tier is not supported on this storage account type

After a couple of weeks, it started working again, and we figured Microsoft had fixed the error. But then a few weeks later our requests stopped working again, and haven't worked since.

This is a StorageV2 (general purpose v2) storage account with ZRS replication located in uksouth.

Our requests are made with the C# azure blob storage library, but using azure storage explorer to attempt to change the access tier produces exactly the same error, which I will attach.

Azure Blob Storage
Azure Blob Storage
An Azure service that stores unstructured data in the cloud as blobs.
2,427 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Amrinder Singh 1,815 Reputation points Microsoft Employee
    2024-03-07T11:31:59.1966667+00:00

    Hi @Tim Dawson - Thanks for reaching out.

    If we check based on region the archive tier is supported in the UK South Region

    https://azure.microsoft.com/en-in/explore/global-infrastructure/products-by-region/?regions=united-kingdom-south,united-kingdom-west&products=storage

    However checking based on redundancy, the archive tier isn’t supported for ZRS account and below are reference links:

    https://learn.microsoft.com/en-us/azure/storage/blobs/access-tiers-overview

    https://learn.microsoft.com/en-us/azure/storage/common/storage-redundancy

    So that seem to be the issue in here. If you have changed the redundancy you might the limitation. You can test with any supported configuration as well.

    Hope that helps!