I have no VMs

Erick B. Decker 0 Reputation points
2024-03-08T16:06:58.58+00:00

I published the template but have 0 VMs? How do I create a VM Pool?

Azure Lab Services
Azure Lab Services
An Azure service that is used to set up labs for classrooms, trials, development and testing, and other scenarios.
279 questions
{count} votes

1 answer

Sort by: Most helpful
  1. deherman-MSFT 33,216 Reputation points Microsoft Employee
    2024-03-12T17:01:34.7133333+00:00

    @Erick B. Decker

    From your response it seems that you have already created the lab template but do not see any VMs created. Please let me know if I am misunderstanding or missing something.

    Once the lab template has been created then started you should be able to publish it and set the number of VMs.

    User's image

    User's image

    Once the Template is running the VM should be able to started from the VM Pool. If necessary, the lab capacity can be changed here as well.

    User's image

    Hopefully this better answers your question. If you are still facing issues please share some screenshots of your configuration and we can investigate those.


    If you still have questions, please let us know in the "comments" and we would be happy to help you. Comment is the fastest way of notifying the experts.

    If the answer has been helpful, we appreciate hearing from you and would love to help others who may have the same question. Accepting answers helps increase visibility of this question for other members of the Microsoft Q&A community.

    Thank you for helping to improve Microsoft Q&A!

    User's image

    0 comments No comments