DFSR Preseeding and Migration shows different file hashes

Shaunm001 301 Reputation points
2024-03-13T17:28:29.85+00:00

We're adding new Server 2022 members to our existing DFSR replication groups (regular file share replicas, not Domain Controller replicas). The existing members are Server 2016 devices. We're using robocopy to preseed the new members as outlined here.

Problem we're having is none of the file hashes match after copying the data from the existing replica members (we're checking file hashes using the Get-DfsrFileHash command as outlined here). Oddly enough the folder hashes all match, but the file hashes don't. I make sure the destination folder doesn't already exist as it states in the Microsoft documentation. I tried using robocopy on the new 2022 server as well as on the old 2016 server, same results.

I also tried skipping preseeding and just letting DFSR copy the files over during initial replication. After I receive the DFSR Event ID 4104 (initial sync finished), I go to check the file hashes and they still don't match. Even weirder, if I check the file hashes again an hour or so after initial sync has completed, then the file hashes match.

Has anyone else had this same experience? Is there some sort of interoperability issue between Server 2022 and Server 2016?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,109 questions
0 comments No comments
{count} votes