deps.json does not exist

Agustín 0 Reputation points
2024-03-15T11:59:03.01+00:00

User's image

Hello everyone!! I am a junior programmer trying to make a project in .NET MAUI, but when it comes to scaffolding my database, I get the following error:

The specified deps.json [C:\Users\Developer\source\repos\MauiTest7\MauiTest7\bin\Debug\net7.0-android\MauiTest7.deps.json] does not exist

I have tried everything, rebuild project, clean, changing from version 7.0 to 8.0 and nothing.

I have pushed ChatGPT to the limit and it hasn't solved anything for me. I've been dealing with this for +5 hours and I've seen many forums but nothing has managed to solve the problem for me.

I'm a little desperate now, because I don't know what to do anymore and that's why I come to this forum. I hope someone can help me.

Thanks a lot!

.NET
.NET
Microsoft Technologies based on the .NET software framework.
3,347 questions
.NET MAUI
.NET MAUI
A Microsoft open-source framework for building native device applications spanning mobile, tablet, and desktop.
2,845 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Bawkn 0 Reputation points
    2024-03-16T23:18:12.8866667+00:00

    hello :),

    I face the same issue as you. I'm not sure if what I'm saying is 100% correct or not. This is my first post, and I'm also a junior. However, I believe Maui doesn't create a deps.json file because it targets framework net8.0-ios/android, etc but not net8.0. At least, that's how I perceive it.

    Additionally, if I'm not mistaken, the official documentation suggests using sqlite-net-pcl.

    Furthermore, I'm not certain if this is feasible, but perhaps we could work around the migration generation by using another project, such as a console project, solely for the execution context?

    0 comments No comments

  2. yannick 0 Reputation points
    2024-03-26T14:40:23.6066667+00:00

    Getting same trouble after moving project to new folder.

    solved it by removing all /bin / obj /.vs folders.

    Rebuild all

    0 comments No comments