RDP to Azure VM with sound - Mic is not coming over

Victor 0 Reputation points
2024-03-18T19:56:00.3666667+00:00

trying to connect to Azure VM and use Teams on the VM, but Microphone does not come over

modified the RDP file and selected to bring audio over.

This work fine when i RDP to any other Windows machine, but not on the Azure VM

Does Microsoft put something in place to block MIC access ?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,092 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,229 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Jackson Martins 9,641 Reputation points MVP
    2024-03-18T20:09:34.33+00:00

    Hi @Victor

    You need to do some steps for the microphone and video to work, I answered a question here that shows how to do this

    https://learn.microsoft.com/en-us/answers/questions/957460/microphone-and-video-not-working

    The steps I did, I went in the group policy of the windows client run -> gpedit.msc Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client > RemoteFX USB Device Redirection - set "Allow RDP redirection of other supported RemoteFX USB devices from this computer" option to Enabled. ensure that the RemoteFX USB Redirection Access Rights are set to "Administrators and Users" 229214-remote-redirection-1.png

    Also configure the other policie: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection - set "Allow audio and video playback redirection" to Enabled

    229235-remote-redirection-2.png

    On the server I configured the policies: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services> Remote Desktop Session Host > Remote Session Environment > RemoteFX for Windows Server 2008 R2 -set "Configure RemoteFX" to Enabled

    229207-remote-redirection-3.png

    Restart your computer and server (or run gpedit /force) and you will see that a new option will appear on your client: 229169-remote-redirection-4.png

    If your device supports it you will be able to use

    Get in touch if you need more help with this issue.

    --please don't forget to "[Accept the answer]" if the reply is helpful