Can't delete a logical network

Kevin COOKE 20 Reputation points
2024-03-20T15:43:28.76+00:00

When trying to delete a logical network, I get the following error;

There was some error while deleting logical network: VLAN_3508_3_5_DPT_Jumpbox_Area. 200: admission webhook "deletionvalidationwebhook.infrastructure.azstackhci.microsoft.com" denied the request: Deletion of default/vlan-3508-3-5-dpt-jumpbox-area failed. It is in use by other resources. Resource type: *v1alpha1.AzStackHCILogicalNetwork

There are no VMs built or running. There are no NIC resources (visible by showing hidden resources). Have also tried the CLI to remove. Any way to find out what is using the network (which I doubt)?

Azure Stack HCI
Azure Stack HCI
A hyperconverged infrastructure operating system delivered as an Azure service that provides security, performance, and feature updates.
263 questions
{count} votes

1 answer

Sort by: Most helpful
  1. benjamin_frempong 5 Reputation points
    2024-03-28T13:55:24.6933333+00:00

    Here's what worked for me. Look under the resources for the custom location and delete the logical networking object.

    User's image

    1 person found this answer helpful.
    0 comments No comments