Cannot log in to Samba after applying 23H2 windows update

Rick Hollinbeck 0 Reputation points
2024-03-20T21:23:43.17+00:00

When applying the 23H2 windows update that came in, a client to Windows 11 Pro machine can no longer log into the local Active Domain (a Samba server).

The error is "unrecognized password".

Booting into Safe Mode and removing the update restores login as before.

I have tried applying the update twice, with the same results, having to uninstall it.

How can I fix this?

Or... Can I mark the 23H2 update somehow so it will not install until this is fixed?

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,077 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Hania Lian 7,551 Reputation points Microsoft Vendor
    2024-03-22T02:46:23.19+00:00

    Hello,

    It appears the 23H2 update is causing compatibility issues with your client’s Active Directory setup. Here are some steps you can take:

    1. Change Group Policy: There is a way to defer updates on specific machines using Group Policy. Press Win + R, type gpedit.msc and press Enter. Go to “Administrative Templates” > “Windows Components” > “Windows Update” > “Defer Windows Updates”. Select “Select when Feature Updates are received” and set it to “Enabled”. You can set it to defer for several months.
    2. Use the “Show or hide updates” troubleshooter package: You can download and run the “Show or hide updates” troubleshooter package from the Microsoft website. It will provide an option to hide problematic updates and prevent them from installing automatically.
    3. Investigate Further: If the problem persists, further investigation may be needed. Check the Windows Event Viewer for any related error messages or warnings that could point towards the cause of the issue.

    Best Regards,

    Hania Lian

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    0 comments No comments