SCSM Setup Cannot Complete Custom Action failed CreateSrsFolder_SC


I'm installing a Microsoft System Center Service Manager, Console and Reporting Server.  This is two servers scenario where SM Console, SM Database and Portal on first server.  and Data Warehouse and DataWH DB will be on the second server.  I'm using Service Manager 2019 and SQL Server 2019, as well as reporting Server. the issue appear while installing the Service Manager Data warehouse.  After finishing the DB and account configuration.  some work is being made by the application like:-  Initialize Installed Files  Create Database  Configure Registry settings   Configure Server.  and finally *** Install Services ***, that's where the below error take place.  \An error occurred while executing a custom action:_CreateSrsFolder_SC This upgrade attempt has failed before permanent modifications were made. Upgrade has successfully rolled back to the original state of the system. Once the correction are made, you can retry upgrade for this role.!


Microsoft System Center
Microsoft System Center
A suite of Microsoft systems management products that offer solutions for managing datacenter resources, private clouds, and client devices.
817 questions
0 comments No comments
{count} votes

Accepted answer
  1. XinGuo-MSFT 14,161 Reputation points


    It looks like the issue is related to reporting service.

    Please try the following solution:

    When installing Data Warehouse server system will checked all the services automatically. After installed(Initialize, Install File, Create database Configure registry setting, configure server), reporting service is stop automatically, system can't start itself, need to start manually from services.msc and start sql server reporting service.

    Note: open services.msc while installing Data warehouse server and press refresh when stop SQL server reporting service, manually start service again.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. 2024-03-26T00:10:26.02+00:00


    0 comments No comments