App and browser control won't open

Anonymous
2024-03-26T02:36:57.5966667+00:00

Hi. Just had a question about Windows 11 Windows security. In Windows Security, the App and Browser Controls won't open and says action is needed with a yellow warning sign. I just noticed it and have tried several things I found like opening powershell and comand prompts. Restarting, I tried the troubleshooter also. While I was trying to fix it I noticed I couldn't reinstall Windows 11 either. I would prefer not having to reset my PC but it's looking like I might have to. Any suggestions would be appreciated.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,106 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Daisy Zhou 18,701 Reputation points Microsoft Vendor
    2024-03-26T08:28:21.89+00:00

    Hello Fred Vorhees,

    Thank you for posting in Q&A forum.

    I understand that you are experiencing an issue with the App and Browser Controls in Windows Security on Windows 11.

    To resolve this issue, you can try the following steps:

    1. Restart your computer and check if the issue persists.
    2. Run the Windows Security troubleshooter by going to Settings > Update & Security > Troubleshoot > Additional troubleshooters > Windows Security.
    3. Make sure that your Windows 11 is up to date by going to Settings > Update & Security > Windows Update.
    4. Reset the Windows Security app by going to Settings > Apps > Apps & features > Windows Security > Advanced options > Reset.
    5. If none of the above steps work, you can try resetting your PC by going to Settings > Update & Security > Recovery > Reset this PC.

    I hope the information above is helpful.

    If you have any questions or concerns, please feel free to let us know.

    Best Regards,

    Daisy Zhou

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.


  2. Fred Vorhees 0 Reputation points
    2024-03-28T08:42:10.7233333+00:00

    I think I solved it. For some reason in Apps > Default Apps > Windows Security under set default file types or link types I was using Windows Security for ".all" files, so I switched it to another app. Now the "Action Reccomended" warning is gone.

    0 comments No comments