Error 1603 while installing MSDE 2000 Release A

spuser15 20 Reputation points
2024-03-29T17:37:51.89+00:00

I was trying to install SQL Server Desktop Engine 2000 Release A for compatibility with an old ASP.NET application, but when I try to install it, I don't see an MSSQL$<instancename> service running, or anywhere. This is the line I used to install:
setup SAPWD="wordpass3" INSTANCENAME="mydatabase1" SECURITYMODE=SQL /L*v setuplog_1.txt

The setup log is attached.

When I used the troubleshooting "guide" in the readme file, it told me to search for string "value 3" in the log and look for a custom action for the error code. When I did this, I found this line:

CustomAction SetPropSQLMSDEInstalled.2D02443E_7002_4C0B_ABC9_EAB2C064397B returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

I don't know anything about error 1603 since it is not listed anywhere in the readme. Please help.

Other info:

KB page used to find download page: https://learn.microsoft.com/ru-ru/security-updates/windowsupdateservices/18148960

Download page used to get MSDE installer: https://web.archive.org/web/20051226022505/http://www.microsoft.com/downloads/details.aspx?FamilyID=413744d1-a0bc-479f-bafa-e4b278eb9147&DisplayLang=en#filelist

MSDE installer direct link decoded from (broken) link on page: https://web.archive.org/web/20240104063752/https://download.microsoft.com/download/D/5/4/D5402C33-65DE-4464-9D82-D1DE2971D9DB/MSDE2000A.exe

Windows 11 x64 Intel 12th Gen Core i7-12650H

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,633 questions
{count} votes

Accepted answer
  1. Erland Sommarskog 100.8K Reputation points MVP
    2024-03-29T18:19:35.55+00:00

    You are trying to install SQL 2000 on Windows 11? Well, you tried, and it failed.

    Build a VM with an operating system that is ancient enough to permit SQL 2000 to run. Myself, I run my SQL 2000 instance on Windows 2000. But I think that Windows XP may work.

    With Windows 11, there is a general issue which affects even the most recent version of SQL Server, and Microsoft has published an article with workarounds. In case you have to have a disk drive that causes the problem, you can try these workarounds. But I would be very surprised if you are able to install SQL 2000 on Windows 11. (I have tried to install SQL 2005 on both Windows 10 and Windows 11. If failed in both cases, but for Windows 10 I applied a workaround I found somewhere.)


1 additional answer

Sort by: Most helpful
  1. MikeyQiao-MSFT 325 Reputation points Microsoft Vendor
    2024-04-01T09:39:05.1466667+00:00

    Hi,@spuser15

    Error 1603 reveals a fatal error occurred during

    installation."2D02443E_7002_4C0B_ABC9_EAB2C064397B" from MSI folder was failed to install.

    To figure out why this is the case, a more detailed and complete setup log is needed. Please attach it.

    However, I found similar problems in the installation process with yours.https://groups.google.com/g/microsoft.public.win2000.msi/c/WEGxHiv0v2o

    You can try to change the StreamSupportFiles sequence in one table in the MSI file.

    Hope my answer may help you.

    0 comments No comments