Connecting to MySQL Flexible Server in Azure suddenly failing

Chris Sadler 0 Reputation points
2024-04-02T15:08:03.6733333+00:00

I have a MySQL instance in Azure which has run fine for about 2+ years.

I have a Function App which inserts some data into on a monthly basis which has failed this month with the following error:
Result: Failure Exception: InterfaceError: 2026 (HY000): SSL connection error: error:1408F10B:SSL routines:ssl3_get_record**:wrong version number** Stack: File "/azure-functions-host/workers/python/3.9/LINUX/X64/azure_functions_worker/dispatcher.py"

So I have tried from my PC using MySQL Workbench and get the exact same error. Also tried with MySQL Shell 8.0.36 and the same:
SSL connection error: error:0A00010B:SSL routines::wrong version number

I ran a Wireshark whilst connecting and get the following response:
 08S01Bad handshake

The fact I don't touch/change this thing suggests something in Azure has been tweaked to cause it. I last connected to it probably 2 or 3 weeks ago.

Azure Database for MySQL
Azure Database for MySQL
An Azure managed MySQL database service for app development and deployment.
711 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Rahul Randive 8,181 Reputation points Microsoft Employee
    2024-04-19T16:26:14.84+00:00

    @Chris Sadler

    Is your server in the WestUS1 region? If so, we encountered issues today with a few MySQL servers in that region, resulting in connectivity problems for customers.

    However, it appears that the issue has now been resolved.

    Thank You!

    0 comments No comments