WebXR "Enter AR" not working on Edge on HoloLens 2

MalDuffin 5 Reputation points

I've been trying to get WebXR running on my HoloLens 2 now for a while, but it's not working.

I've got a project running on 8th Wall that I would like to test ( note that it works fine on Quest 3 browser )

As it wasn't working, I looked for basic test links, the first two WebXR Sample links on the Immersive Web site seem to be ones that should just work. On my HoloLens 2, they don't.

Here's the steps I take...

  • Visit the site at https://immersive-web.github.io/webxr-samples/ ( search WebXR demo and this should be one of the first sites to appear )
  • Run the 2 - Immersive AR Session link ( click on the title )
  • Press Start AR / Allow the AR permissions

If I check the developer console, I see these two messages...

Could not create a session because something went wrong initialising the session in the runtime,


XRSession creation failed: The specified session configuration is not supported

In edge://flags, search for XR - all 3 were set to default. I also set them to Enabled, OpenXR, Enabled.

When I click on the Lock icon beside the website URL, I see...
Permissions for this site: Augmented Reality: Allow

I had Windows Updated to the latest version.

I then Reset the device, which didn't help.

I then joined the Windows Insider program, selecting the Beta Channel.

I then got into that loop where you press Restart by clicking on your icon, it shows Update/Restart update/Shutdown, but it got stuck in a loop,.

I was able to then Reset the device again. When I reset, it showed up that I'm in Windows Insider, and Windows Update doesn't show any updates.

Under About / Windows Specifications...

Edition: Windows Holographic for Business

OS Build: 22621.1324

Activation Status: Windows is activated

If anyone has any suggestions, I'd be grateful! I'm keen to just see one example of WebXR running on the device.

It would be great to get it running on Edge of course, but if anyone has tried WebXR on Hololens using a different browser, I'm up for trying that too.

Thanks in advance for any help...


HoloLens Development
HoloLens Development
HoloLens: A family of Microsoft self-contained, holographic devices that enable engagement with digital content and interaction with holograms in the surrounding environment.Development: The process of researching, productizing, and refining new or existing technologies.
387 questions
{count} votes

1 answer

Sort by: Most helpful
  1. MalDuffin 5 Reputation points

    I got it working! Firstly, many thanks to two developers for reaching out to me letting me know they got it working - I was able to run a few different combinations to get it working. I then broke it again on purpose ( by updating OpenXR ), and then re-installed using the steps below to get it working again ( so that, if something goes wrong before the demo I'm running, I can fix it )

    I needed to use the Advanced Recovery Companion* to install a downloaded version of v22621.1266, and then do a software update to v22621.1272* ( * links at bottom of post )

    If I did the install of v22621.1272 directly, it doesn't work!!!

    I also tried various older versions, including...

    A few key things...

    1. As soon as you choose to update OpenXR ( from 1.0.18 to 1.0.28 ), all WebXR breaks. This obviously isn't good, and will hopefully be fixed soon. Just to confirm, the only change from an instance of WebXR working on Edge and it breaking on the same version of Edge is by just updating OpenXR from 1.0.18 to 1.0.28.
    2. If running on OpenXR 1.0.18 on any of the above versions, the basic WebXR demos work on https://immersive-web.github.io/webxr-samples/ ( 1 and 2 )
    3. However, 8th Wall AR content only works with the setup I described at the top of the screen ( as well as the basic WebXR demos ). This is the best setup if you are currently developing for WebXR, as it emulates the experience you get on other headsets that support WebXR like the Quest 3 ( where the content just works on the headset, which is the goal of WebXR of course )

    Here's an 8th Wall link where you can test if it's working or not.


    If WebXR is set up correctly ( as it is if you follow the instructions at the top ), you will get the Enter AR prompt and enter the immersive 3D space, and see the 3D basketball in front of you.

    If it doesn't work, you'll just see the basketball in the floating browser window, as if it's running in normal desktop mode.

    Hope this helps someone who runs into the same issues, and gives the developers some links to test out and help get it working for a future update for everyone to benefit from - this was a bit of a nightmare to figure out, and a real time sink in terms of waiting around to install different versions / re-logging in etc.

    Download OS


    Download Advanced Recovery Companion