Azure AI Studio - Current Prompt Flow runtime doesn't accept latest version of Semantic Kernel

Lean Stefanutti 0 Reputation points
2024-04-24T21:10:21.9866667+00:00

When I upload a promptflow based on semantic kernel, and then I want to start the runtime, it says it is just accepting semantic kernel version > 0.4.0.dev0 < 0.4.6.dev0 , where the latest version of semantic kernel is 0.9.6b1.

Is there any way / workaround to make Azure AI studio to work with latest version (or at least the most recent ones) of Semantic Kernel?

Thanks!

Lean

Azure AI services
Azure AI services
A group of Azure services, SDKs, and APIs designed to make apps more intelligent, engaging, and discoverable.
2,434 questions
{count} votes

1 answer

Sort by: Most helpful
  1. navba-MSFT 17,395 Reputation points Microsoft Employee
    2024-04-29T06:26:18.0633333+00:00

    @Lean Stefanutti We appreciate your patience on this. I have got an update from the Product Owners on this.

    The Promptflow is waiting for the SK v1.0 release before they take the upgrade. I expect this will be fixed by end of May month.

    We sincerely apologize for any inconvenience caused.

    Hope this helps.

    **

    Please do not forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.