Exchange on-premise to 365 migration doesn't work anymore

GVB 0 Reputation points
2024-04-25T12:35:20.3233333+00:00

Hello,

Since a week our mailbox migration jobs won't complete anymore.

After a while they end with an error as seen below...

Status

Data migrated:

Migration rate:

Error: TimeoutErrorTransientException: The call to 'https://mydomain/EWS/mrsproxy.svc' timed out. Error details: The request channel timed out attempting to send after 00:00:00.0049846. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. --> The HTTP request to 'https://mydomain/EWS/mrsproxy.svc' has exceeded the allotted timeout of 00:00:00.0049846. The time allotted to this operation may have been a portion of a longer timeout. --> The request channel timed out attempting to send after 00:00:00.0049846. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. --> The HTTP request to 'https://mydomain/EWS/mrsproxy.svc' has exceeded the allotted timeout of 00:00:00.0049846. The time allotted to this operation may have been a portion of a longer timeout.

Notice that tiny timeout. that's half a milisecond which seems ridiculous low.

Strange thing is that I can access the EWS page from external without any problems and I get the same page as the last screenshot on this page.

https://www.codetwo.com/kb/how-to-find-ews-url/

I tried disabling en re-abling the proxy with the commands below just to be sure:

Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory -MRSProxyEnabled $false
Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory -MRSProxyEnabled $true

I removed the end point and when creating it with the checkbox ticked to verify it it hang at creating.

With the checkbox unticked it created right away but it still doesn't seem to work.

What else can I check to get this working again? (it used to work fine for 2+ years but sometime this error showed up and then I just had to restart the sync or worst case delete the migration task and recreate it)

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,381 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,908 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Noah Ma-MSFT 995 Reputation points Microsoft Vendor
    2024-04-26T09:25:04.7966667+00:00

    Hi @GVB,

    According to the information above, you could refer to the followings:

    1. Check again the on-premises infrastructure, especially proxy and firewall settings. Ensure your firewall settings to allow connections from O365. You can refer to Microsoft 365 URLs and IP address ranges - Microsoft 365 Enterprise | Microsoft Learn for more information.
    2. You could check your network devices logs and IIS logs / HTTPProxy logs, usually if the timeout happens very quick (under 50 sec) it could probably be a network device that is blocking or closing the connection.
    3. Also, check if exchange self-signed certificate is missing in the Exchange Servers.

    You can refer scenario 1 in the document for more information: Troubleshooting Hybrid Migration Endpoints in Classic and Modern Hybrid - Microsoft Community Hub